php5-5.6.33-2vl7.src.rpm(Please reinstall the libzip distribution)

.3 をリビルド時に、以下のメッセージが表示しました。

Please reinstall the libzip distribution

どうも、libzip を導入する必要があるみたいです

早速、以下のコマンドで導入する事にしました。

apt-get install libzip libzip-devel

また、以下のソフトを導入する事に成功しました。

libzip 0.9.3-2vl6
libzip-devel 0.9.3-2vl6

早速、再度、リビルドを実行すると

以下のメッセージが表示しました。

configure: error: system libzip must be upgraded to version >= 0.11

どうも、libzip のバージョンが、0.11以上が必要みたいです

その為、以下の方法で、1.3.2 をリビルドする事にしました。

①.libzip-0.9.3-2vl6.src.rpm を入手します。

apt-get source libzip

②.libzip-0.9.3-2vl6.src.rpmを解凍します。

rpm -ivh libzip-0.9.3-2vl6.src.rpm

③.SOURCES の場所に移動します。

cd ~/rpm/SOURCES

④.libzip-1.3.2.tar.xz をダウンロードします。

wget https://libzip.org/download/libzip-1.3.2.tar.xz

⑤.libzip-vl.spec の場所に移動する。

cd ~/rpm/SPECS

⑥.libzip-vl.spec を編集します。

vi libzip-vl.spec

変更前

Version:        0.9.3

変更後

Version:        1.3.2

3行目を修正します。

変更前

Source0:        http://www.nih.at/libzip/%{name}-%{version}.tar.bz2

変更後

Source0:        http://www.nih.at/libzip/%{name}-%{version}.tar.xz

9行目を修正します。

変更前

%files
%defattr(-,root,root,-)
%doc AUTHORS NEWS README THANKS TODO
%{_bindir}/zipcmp
%{_bindir}/zipmerge
%{_bindir}/ziptorrent
%{_libdir}/libzip.so.1*
%{_mandir}/man1/*zip*

%files devel
%defattr(-,root,root,-)
%{_includedir}/zip.h
%{_libdir}/libzip.so
%{_libdir}/pkgconfig/libzip.pc
%{_mandir}/man3/*zip*

変更後

%files
%defattr(-,root,root,-)
%doc LICENSE* AUTHORS* NEWS* README* THANKS* TODO*
%{_bindir}/*
%{_libdir}/libzip.so.*
%{_mandir}/man1/*zip*

%files devel
%defattr(-,root,root,-)
%{_includedir}/*
%{_libdir}/libzip.so
%{_libdir}/pkgconfig/libzip.pc
%{_mandir}/man3/*

56行目から66行目を修正します。

⑦.リビルド開始

rpm -ba libzip-vl.spec > libzip-vl.log &

 

リビルド後

libzip-1.3.2-2vl6.x86_64.rpm
libzip-devel-1.3.2-2vl6.x86_64.rpm

 

コメントを残す

サブコンテンツ

カレンダー

2018年2月
« 1月    
 1234
567891011
12131415161718
19202122232425
262728  

賢威

電脳卸

天気予報


-天気予報コム-

お奨め情報

COUNTER

合計:70211
本日:15
昨日:56
訪問者:0

このページの先頭へ