apache2-2.4.17(Apache HTTP Server 2.4.17)

最新版のapache2-2.4.17-1vl7.src.rpmが出てました

また、同時接続数(MaxClients)を変更してみますnotes

①.wget http://updates.vinelinux.org/VineSeed/pool/apache2-2.4.17-1vl7.src.rpm

ソースファイルを入手します。

②.rpm -ivh apache2-2.4.17-1vl7.src.rpm

apache2-2.4.17-1vl7.src.rpmを解凍します。

③.cd ~/rpm/SOURCES

SOURCESに移動します。

④.tar zxvf httpd-2.4.17.tar.bz2

httpd-2.4.17.tar.bz2を解凍します。

⑤.vi httpd-2.4.17/server/mpm/prefork/prefork.c

prefork.c を編集します。

変更前

#define DEFAULT_SERVER_LIMIT 256

変更後

#define DEFAULT_SERVER_LIMIT 10000

25610000に変更します。

⑥.vi httpd-2.4.17/server/mpm/worker/worker.c

worker.c を編集します。

変更前

#define DEFAULT_SERVER_LIMIT 16

変更後

#define DEFAULT_SERVER_LIMIT 10000

1610000に変更します。

⑦.rm httpd-2.4.17.tar.bz2

httpd-2.4.17.tar.bz2を削除します。

⑧.tar -jcvf httpd-2.4.17.tar.bz2 httpd-2.4.17/

httpd-2.4.17.tar.bz2として圧縮します。

⑨.cd ~/rpm/SPECS

apache2-vl.spec がある場所に移動します。

⑩.rpm -ba apache2-vl.spec >apache2-vl.log &

リビルドを開始します

リビルドを開始すると以下のソフトが必要でした

xmlto は apache2-2.4.17-1vl6.x86_64 に必要とされています
lua-devel は apache2-2.4.17-1vl6.x86_64 に必要とされています
www-common は apache2-2.4.17-1vl6.x86_64 に必要とされています

リビルドする事が出来ませんでした

バックアップ後にリビルドする事にします

コメントを残す

サブコンテンツ

カレンダー

2018年2月
« 1月    
 1234
567891011
12131415161718
19202122232425
262728  

賢威

電脳卸

天気予報


-天気予報コム-

お奨め情報

COUNTER

合計:70211
本日:15
昨日:56
訪問者:0

このページの先頭へ